Yes, you are getting this error because of Symantec and Google Chrome SSL distrust issue.

Chrome version 66 will distrust all Symantec SSL , If

1. Your SSL is issued before June 1, 2016 and...